MWI Subscription Fails with "404 Not Found" (Sieme

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

MWI Subscription Fails with "404 Not Found" (Sieme

Postby mr-3007 » Mon Dec 31, 2007 6:24 am

Hello all,

I have a strange problem with my Siemens S450 IP connecting to Asterisk 1.3.16.2

The Phone registers succesfully, but when it tries to subscribe for MWI messages (it does not accept unsubscribed MWI Notifications), I always get "404 - Not Found"

I have tried various things in my config-files - always the same story (see below)

Any ideas? Is there something special to configure to allow MWI Subscriptions with SIP Phones?

How can I increase the debug level in chan_sip.c (I saw much more verbose output in other threads)

regards
Michael


[Dec 31 13:23:07] VERBOSE[7337] logger.c:
<--- SIP read from 192.168.0.13:5060 --->
REGISTER sip:asterisk SIP/2.0
Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK2874846679788c1fe8892cc4f918d32e;rport
From: "3000" <sip:3000@asterisk>;tag=3316210862
To: "3000" <sip:3000@asterisk>
Call-ID: 1583655436@192_168_0_13
CSeq: 253 REGISTER
Contact: <sip:3000@192.168.0.13:5060>
Max-Forwards: 70
User-Agent: S450 IP020970000000
Expires: 180
Allow: INVITE, ACK, CANCEL, BYE, OPTIONS, INFO, REFER, SUBSCRIBE, NOTIFY
Content-Length: 0


<------------->
[Dec 31 13:23:07] VERBOSE[7337] logger.c: --- (12 headers 0 lines) ---
[Dec 31 13:23:07] DEBUG[7337] chan_sip.c: Allocating new SIP dialog for 1583655436@192_168_0_13 - REGISTER (No RTP)
[Dec 31 13:23:07] VERBOSE[7337] logger.c: Using latest REGISTER request as basis request
[Dec 31 13:23:07] VERBOSE[7337] logger.c: Sending to 192.168.0.13 : 5060 (NAT)
[Dec 31 13:23:07] VERBOSE[7337] logger.c:
<--- Transmitting (no NAT) to 192.168.0.13:5060 --->
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK2874846679788c1fe8892cc4f918d32e;received=192.168.0.13;rport=5060
From: "3000" <sip:3000@asterisk>;tag=3316210862
To: "3000" <sip:3000@asterisk>
Call-ID: 1583655436@192_168_0_13
CSeq: 253 REGISTER
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Contact: <sip:3000@192.168.0.10>
Content-Length: 0


<------------>
[Dec 31 13:23:07] VERBOSE[7337] logger.c:
<--- Transmitting (no NAT) to 192.168.0.13:5060 --->
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK2874846679788c1fe8892cc4f918d32e;received=192.168.0.13;rport=5060
From: "3000" <sip:3000@asterisk>;tag=3316210862
To: "3000" <sip:3000@asterisk>;tag=as7025c0e3
Call-ID: 1583655436@192_168_0_13
CSeq: 253 REGISTER
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
WWW-Authenticate: Digest algorithm=MD5, realm="asterisk", nonce="3e52cea5"
Content-Length: 0


<------------>
[Dec 31 13:23:07] VERBOSE[7337] logger.c: Scheduling destruction of SIP dialog '1583655436@192_168_0_13' in 32000 ms (Method: REGISTER)
[Dec 31 13:23:07] VERBOSE[7337] logger.c:
<--- SIP read from 192.168.0.13:5060 --->
REGISTER sip:asterisk SIP/2.0
Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK8c47bd295b600a56c0a594ef953314c;rport
From: "3000" <sip:3000@asterisk>;tag=3316210862
To: "3000" <sip:3000@asterisk>
Call-ID: 1583655436@192_168_0_13
CSeq: 254 REGISTER
Contact: <sip:3000@192.168.0.13:5060>
Authorization: Digest username="3000", realm="asterisk", algorithm=MD5, uri="sip:asterisk", nonce="3e52cea5", response="1c16a6ccaa0efa3d2f71b1d8ccc4a8e7"
Max-Forwards: 70
User-Agent: S450 IP020970000000
Expires: 180
Allow: INVITE, ACK, CANCEL, BYE, OPTIONS, INFO, REFER, SUBSCRIBE, NOTIFY
Content-Length: 0


<------------->
[Dec 31 13:23:07] VERBOSE[7337] logger.c: --- (13 headers 0 lines) ---
[Dec 31 13:23:07] VERBOSE[7337] logger.c: Using latest REGISTER request as basis request
[Dec 31 13:23:07] VERBOSE[7337] logger.c: Sending to 192.168.0.13 : 5060 (NAT)
[Dec 31 13:23:07] VERBOSE[7337] logger.c:
<--- Transmitting (no NAT) to 192.168.0.13:5060 --->
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK8c47bd295b600a56c0a594ef953314c;received=192.168.0.13;rport=5060
From: "3000" <sip:3000@asterisk>;tag=3316210862
To: "3000" <sip:3000@asterisk>
Call-ID: 1583655436@192_168_0_13
CSeq: 254 REGISTER
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Contact: <sip:3000@192.168.0.10>
Content-Length: 0


<------------>
[Dec 31 13:23:07] VERBOSE[7337] logger.c: -- Saved useragent "S450 IP020970000000" for peer 3000
[Dec 31 13:23:07] VERBOSE[7337] logger.c:
<--- Transmitting (no NAT) to 192.168.0.13:5060 --->
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK8c47bd295b600a56c0a594ef953314c;received=192.168.0.13;rport=5060
From: "3000" <sip:3000@asterisk>;tag=3316210862
To: "3000" <sip:3000@asterisk>;tag=as7025c0e3
Call-ID: 1583655436@192_168_0_13
CSeq: 254 REGISTER
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Expires: 180
Contact: <sip:3000@192.168.0.13:5060>;expires=180
Date: Mon, 31 Dec 2007 12:23:07 GMT
Content-Length: 0


<------------>
[Dec 31 13:23:07] VERBOSE[7337] logger.c: Scheduling destruction of SIP dialog '1583655436@192_168_0_13' in 32000 ms (Method: REGISTER)
[Dec 31 13:23:08] VERBOSE[7337] logger.c:
<--- SIP read from 192.168.0.13:5060 --->
SUBSCRIBE sip:3000@asterisk SIP/2.0
Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK3202997de3557c4ad3038778c91d2bb4;rport
From: "3000" <sip:3000@asterisk>;tag=971116178
To: "3000" <sip:3000@asterisk>
Call-ID: 133642293@192_168_0_13
CSeq: 2088787950 SUBSCRIBE
Contact: <sip:3000@192.168.0.13:5060>
Max-Forwards: 70
User-Agent: S450 IP020970000000
Event: message-summary
Expires: 3600
Allow: NOTIFY
Accept: application/simple-message-summary
Content-Length: 0


<------------->
[Dec 31 13:23:08] VERBOSE[7337] logger.c: --- (14 headers 0 lines) ---
[Dec 31 13:23:08] DEBUG[7337] chan_sip.c: Allocating new SIP dialog for 133642293@192_168_0_13 - SUBSCRIBE (No RTP)
[Dec 31 13:23:08] VERBOSE[7337] logger.c: Creating new subscription
[Dec 31 13:23:08] VERBOSE[7337] logger.c: Sending to 192.168.0.13 : 5060 (NAT)
[Dec 31 13:23:08] VERBOSE[7337] logger.c: Found peer '3000'
[Dec 31 13:23:08] VERBOSE[7337] logger.c: Looking for 3000 in default (domain asterisk)
[Dec 31 13:23:08] VERBOSE[7337] logger.c:
<--- Transmitting (no NAT) to 192.168.0.13:5060 --->
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK3202997de3557c4ad3038778c91d2bb4;received=192.168.0.13;rport=5060
From: "3000" <sip:3000@asterisk>;tag=971116178
To: "3000" <sip:3000@asterisk>;tag=as69b987a3
Call-ID: 133642293@192_168_0_13
CSeq: 2088787950 SUBSCRIBE
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Content-Length: 0


<------------>
[Dec 31 13:23:08] VERBOSE[7337] logger.c: Really destroying SIP dialog '133642293@192_168_0_13' Method: SUBSCRIBE
[Dec 31 13:23:08] DEBUG[7337] chan_sip.c:
---------- SIP HISTORY for '133642293@192_168_0_13'
[Dec 31 13:23:08] DEBUG[7337] chan_sip.c: * SIP Call
[Dec 31 13:23:08] DEBUG[7337] chan_sip.c: 001. Rx SUBSCRIBE / 2088787950 SUBSCRIBE / sip:3000@asterisk
[Dec 31 13:23:08] DEBUG[7337] chan_sip.c: 002. TxResp SIP/2.0 / 2088787950 SUBSCRIBE - 404 Not Found
[Dec 31 13:23:08] DEBUG[7337] chan_sip.c:
---------- END SIP HISTORY for '133642293@192_168_0_13'
[Dec 31 13:23:09] VERBOSE[7337] logger.c:
<--- SIP read from 192.168.0.13:5060 --->
SUBSCRIBE sip:3000@asterisk SIP/2.0
Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK988cc0c45f96a8f63fb2d10729df1f56;rport
From: "3000" <sip:3000@asterisk>;tag=622880204
To: "3000" <sip:3000@asterisk>
Call-ID: 2679052271@192_168_0_13
CSeq: 758380643 SUBSCRIBE
Contact: <sip:3000@192.168.0.13:5060>
Max-Forwards: 70
User-Agent: S450 IP020970000000
Event: message-summary
Expires: 3600
Allow: NOTIFY
Accept: application/simple-message-summary
Content-Length: 0


<------------->
[Dec 31 13:23:09] VERBOSE[7337] logger.c: --- (14 headers 0 lines) ---
[Dec 31 13:23:09] DEBUG[7337] chan_sip.c: Allocating new SIP dialog for 2679052271@192_168_0_13 - SUBSCRIBE (No RTP)
[Dec 31 13:23:09] VERBOSE[7337] logger.c: Creating new subscription
[Dec 31 13:23:09] VERBOSE[7337] logger.c: Sending to 192.168.0.13 : 5060 (NAT)
[Dec 31 13:23:09] VERBOSE[7337] logger.c: Found peer '3000'
[Dec 31 13:23:09] VERBOSE[7337] logger.c: Looking for 3000 in default (domain asterisk)
[Dec 31 13:23:09] VERBOSE[7337] logger.c:
<--- Transmitting (no NAT) to 192.168.0.13:5060 --->
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK988cc0c45f96a8f63fb2d10729df1f56;received=192.168.0.13;rport=5060
From: "3000" <sip:3000@asterisk>;tag=622880204
To: "3000" <sip:3000@asterisk>;tag=as0653866b
Call-ID: 2679052271@192_168_0_13
CSeq: 758380643 SUBSCRIBE
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Content-Length: 0


<------------>
[Dec 31 13:23:09] VERBOSE[7337] logger.c: Really destroying SIP dialog '2679052271@192_168_0_13' Method: SUBSCRIBE
[Dec 31 13:23:09] DEBUG[7337] chan_sip.c:
---------- SIP HISTORY for '2679052271@192_168_0_13'
[Dec 31 13:23:09] DEBUG[7337] chan_sip.c: * SIP Call
[Dec 31 13:23:09] DEBUG[7337] chan_sip.c: 001. Rx SUBSCRIBE / 758380643 SUBSCRIBE / sip:3000@asterisk
[Dec 31 13:23:09] DEBUG[7337] chan_sip.c: 002. TxResp SIP/2.0 / 758380643 SUBSCRIBE - 404 Not Found
[Dec 31 13:23:09] DEBUG[7337] chan_sip.c:
---------- END SIP HISTORY for '2679052271@192_168_0_13'
[Dec 31 13:23:10] VERBOSE[7337] logger.c:
<--- SIP read from 192.168.0.50:5065 --->
REGISTER sip:192.168.0.10 SIP/2.0
Via: SIP/2.0/UDP 192.168.0.50:5065;branch=z9hG4bK-7ef8724b
From: "spa962" <sip:spa962@192.168.0.10>;tag=9587439b4553d1a2o5
To: "spa962" <sip:spa962@192.168.0.10>
Call-ID: ace29ba3-374d151e@192.168.0.50
CSeq: 63997 REGISTER
Max-Forwards: 70
Authorization: Digest username="spa962",realm="asterisk",nonce="6edcb23a",uri="sip:192.168.0.10",algorithm=MD5,response="fda37a779d8af195b8eef0ccc91e5501"
Contact: "spa962" <sip:spa962@192.168.0.50:5065>;expires=3600;+sip.instance="<00000000-0000-0000-0000-000E08DD6411>"
User-Agent: Linksys/SPA962-5.1.3
P-Station-Name: Mike Arbeitszimmer ;mac=000e08dd6411
Content-Length: 0
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER, SUBSCRIBE
Allow-Events: dialog
Supported: replaces
mr-3007
Newsterisk
 
Posts: 7
Joined: Mon Dec 31, 2007 6:08 am

Postby ianplain » Mon Dec 31, 2007 10:40 am

Hi What does the sip.conf for this set look like?
Ian
ianplain
Moves Like Spencer
 
Posts: 3076
Joined: Thu Dec 14, 2006 7:01 am
Location: Bath, UK

Postby mr-3007 » Mon Dec 31, 2007 11:00 am

Hi Ian,

here is my sip.conf for this phone:

[3000]
type=friend ; Friends place calls and receive calls
regexten=3000
insecure=very
context=default
secret=Gigaset
subscribecontext=default ; Only allow SUBSCRIBE for local extensions
language=de ; Use German prompts for this user
host=dynamic ; This peer register with us
dtmfmode=inband ; Choices are inband, rfc2833, or info
mailbox=3000@default ; Mailbox(-es) for message waiting indicator
allowsubscribe
subscribemwi=yes ; Only send notifications if this phone
; subscribes for mailbox notification
;vmexten=3001 ; dialplan extension to reach mailbox
; sets the Message-Account in the MWI notify message
; defaults to global vmexten which defaults to "asterisk"
allow=ulaw ; dtmfmode=inband only works with ulaw or alaw!

Thanks for any Ideas and a happy new year
Michael
mr-3007
Newsterisk
 
Posts: 7
Joined: Mon Dec 31, 2007 6:08 am

Postby ianplain » Mon Dec 31, 2007 12:04 pm

try

[3000]
type=friend ; Friends place calls and receive calls
regexten=3000
insecure=very
context=default
secret=Gigaset
subscribecontext=default ; Only allow SUBSCRIBE for local extensions
language=de ; Use German prompts for this user
host=dynamic ; This peer register with us
dtmfmode=inband ; Choices are inband, rfc2833, or info
mailbox=3000
disallow=all
allow=ulaw ; dtmfmode=inband only works with ulaw or alaw!
ianplain
Moves Like Spencer
 
Posts: 3076
Joined: Thu Dec 14, 2006 7:01 am
Location: Bath, UK

Postby mr-3007 » Tue Jan 01, 2008 4:01 am

Hello Ian,

I've tried your sip.conf example - no change (404 - Not Found)

Do you have an Idea what asterisk is searching for exactly when saying "Not Found"?

Do you know how we can get more debug output from chan_sip.c?

Regards
Michael
mr-3007
Newsterisk
 
Posts: 7
Joined: Mon Dec 31, 2007 6:08 am

Postby ianplain » Tue Jan 01, 2008 6:05 am

Hi

as to debug, you are looking at the sip messages so thats the limit realy.

Now is ext 3000 in the default context in the extensions.conf ?

also do you have any domain entried in the general section of the sip.conf?

you could try adding domain=asterisk,default ; as thats what its looking for.

Ian
ianplain
Moves Like Spencer
 
Posts: 3076
Joined: Thu Dec 14, 2006 7:01 am
Location: Bath, UK

Postby mr-3007 » Tue Jan 01, 2008 11:08 am

Hello Ian,

again - no change.

Do you know a Softphone that supports MWI Subscriptions?

I'd like to check whether it is working with another SIP Device to decide whether it is a problem with * or with the phone. The only Hardphones I have here is a Cisco 7960 and a Linksys SPA 962 (Sipura). Both of them do not support (or require) MWI Subscriptions since I have seen MWI on both devices while runnning Asterisk 1.2.

Regrdas
Michael
mr-3007
Newsterisk
 
Posts: 7
Joined: Mon Dec 31, 2007 6:08 am

Postby AndrewZ » Tue Jan 01, 2008 12:55 pm

Have it working, Asterisk 1.4.16.2, Gigaset S450 IP


Code: Select all
[15]
fullname =
secret = password
context = longdistance
vmsecret = anotherpassword
hasvoicemail = yes
mailbox = 15
hassip = yes
hasiax = no
host = dynamic
dtmfmode = rfc2833
disallow = all
allow = alaw
allow = ulaw
allow = g729
nat = yes
insecure = invite
canreinvite = no 
AndrewZ
Oldsterisk
 
Posts: 220
Joined: Thu Jan 04, 2007 5:58 pm

Postby mr-3007 » Wed Jan 02, 2008 10:58 am

Hello Andrew,

good to hear that it should work in principle. Nevertheless, even with your sip.conf snapshot it does not work for me. Looks like I need some more assistance ;-)

I am using 1.4.16.2. too - this was a type in my first posting.

1. I was wondering why you do not use type- and username-definitions. Without a type-definition, I do not even get my Gigaset registered.

2. Do you have something special in the general sections of sip.conf, extensions,conf or voicemail.conf. Could you send me an extract of your files as pm? I am using modified samples (that come with Asterisk) of the *.conf files. Do you think that could be a problem?

3. What settings did you apply in your S450IP?

Thanks fo a feedback - I am eagerly searching for a solution for this issue since it is the last blocking point that prevents me from using Asterisk in a real life scenario.

Regards
Michael
mr-3007
Newsterisk
 
Posts: 7
Joined: Mon Dec 31, 2007 6:08 am

Postby AndrewZ » Wed Jan 02, 2008 1:03 pm

I see one difference already.

My local machine name is butthead.lan, so I have this name configured in sip.conf (fromdomain = butthead.lan) and on each SIP UA I have.
So, on Siemens 'butthead.lan' is set in Domain, Proxy server address and Registrar server fields.

As a result, I see in the log 15@butthead.lan where you have 3000@asterisk
Last edited by AndrewZ on Mon Mar 10, 2008 5:29 pm, edited 1 time in total.
AndrewZ
Oldsterisk
 
Posts: 220
Joined: Thu Jan 04, 2007 5:58 pm

Postby mr-3007 » Thu Jan 03, 2008 1:42 am

o.k. . I will try.
I will have to set up a DNS in my test environment for that.

Did you use the Asterisk Sample-Files as Basis for your *.conf or did you start from scratch?

Michael
mr-3007
Newsterisk
 
Posts: 7
Joined: Mon Dec 31, 2007 6:08 am

Postby AndrewZ » Thu Jan 03, 2008 6:13 am

yes, I started with the sample files provided with the distribution tar
AndrewZ
Oldsterisk
 
Posts: 220
Joined: Thu Jan 04, 2007 5:58 pm

Postby mr-3007 » Sat Jan 05, 2008 8:31 am

Hello,

a few hours of trubleshooting later, I found the problem:

I was using (only) sip.conf, extensions.conf and voicemail.conf for my configuration since I came from Asterisk 1.2

After I moved all definitions to users.conf, MWI worked also with the Gigaset ans Subscriptions were accepted by Asterisk. I read somewhere that certain configuration elements are only read from users.conf in 1.4. THis could explain why Subscriptions did not work without using that file.

Michael
mr-3007
Newsterisk
 
Posts: 7
Joined: Mon Dec 31, 2007 6:08 am

Postby U4EAGW » Mon Mar 10, 2008 1:26 pm

Hi Machael,

I am new to Asterisk, and ran into the problem that you had.

I am trying to connect a softphone(eyebeam) to Asterisk 1.4.17. The Phone registers succesfully and I can make calls among extensions and check voicemail, but when it tries to subscribe for MWI messages, I always get "404 - Not Found" from the Ethereal capture and "chan_sip.c:14907 handle_request_subscribe: Received SIP subscribe for peer without mailbox: 1004" at Asterisk CLI.

Any idea what I did wrong or missed?

Thanks in advance,

Hui
U4EAGW
Newsterisk
 
Posts: 3
Joined: Mon Mar 10, 2008 1:05 pm

Postby AndrewZ » Mon Mar 10, 2008 5:30 pm

U4EAGW wrote:what ... missed?


the mailbox, according to the debug message
AndrewZ
Oldsterisk
 
Posts: 220
Joined: Thu Jan 04, 2007 5:58 pm


Return to Asterisk Support

Who is online

Users browsing this forum: No registered users and 23 guests