Cisco IP Communicator 8.6.1 with Asterisk

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

Cisco IP Communicator 8.6.1 with Asterisk

Postby joekane » Thu Mar 29, 2012 6:24 am

Hi,

Im trying to get the Cisco IP Communicator registering with my asterisk server.

I have the CIPC installed and picking up the config from a TFTP server

Here is my config - it shows the lines and is stuck on registering.
Is there something I am missing.

Thanks, Joe

Code: Select all
<device>
<deviceProtocol>SIP</deviceProtocol>
<sshUserId>admin</sshUserId>
<sshPassword>password</sshPassword>
<devicePool>
   <dateTimeSetting>
      <dateTemplate>D/M/YA</dateTemplate>
      <timeZone></timeZone>
      <ntps>
         <ntp>
            <name>192.168.1.3</name>
            <ntpMode>Unicast</ntpMode>
         </ntp>         
      </ntps>
   </dateTimeSetting>
   <callManagerGroup>
      <members>
         <member priority="0">
            <callManager>
               <ports>
                  <ethernetPhonePort>2000</ethernetPhonePort>
                  <sipPort>5060</sipPort>
              <ProxyPort>5060</ProxyPort>
                  <securedSipPort>5061</securedSipPort>
               </ports>
               <processNodeName>192.168.1.3</processNodeName>
            </callManager>
         </member>
      </members>
   </callManagerGroup>
</devicePool>
<sipProfile>
   <sipProxies>
      <backupProxy>192.168.1.3</backupProxy>
      <backupProxyPort>5060</backupProxyPort>
      <emergencyProxy></emergencyProxy>
      <emergencyProxyPort></emergencyProxyPort>
      <outboundProxy>192.168.1.3</outboundProxy>
      <outboundProxyPort>5060</outboundProxyPort>
     <ProxyPort>5060</ProxyPort>
      <registerWithProxy>true</registerWithProxy>
   </sipProxies>
   <sipCallFeatures>
      <cnfJoinEnabled>true</cnfJoinEnabled>
      <callForwardURI>x-serviceuri-cfwdall</callForwardURI>
      <callPickupURI>x-cisco-serviceuri-pickup</callPickupURI>
      <callPickupListURI>x-cisco-serviceuri-opickup</callPickupListURI>
      <callPickupGroupURI>x-cisco-serviceuri-gpickup</callPickupGroupURI>
      <meetMeServiceURI>x-cisco-serviceuri-meetme</meetMeServiceURI>
      <abbreviatedDialURI>x-cisco-serviceuri-abbrdial</abbreviatedDialURI>
      <rfc2543Hold>false</rfc2543Hold>
      <callHoldRingback>2</callHoldRingback>
      <localCfwdEnable>true</localCfwdEnable>
      <semiAttendedTransfer>true</semiAttendedTransfer>
      <anonymousCallBlock>2</anonymousCallBlock>
      <callerIdBlocking>2</callerIdBlocking>
      <dndControl>0</dndControl>
      <remoteCcEnable>true</remoteCcEnable>
   </sipCallFeatures>
   <sipStack>
      <sipInviteRetx>6</sipInviteRetx>
      <sipRetx>10</sipRetx>
      <timerInviteExpires>180</timerInviteExpires>
      <timerRegisterExpires>3600</timerRegisterExpires>
      <timerRegisterDelta>5</timerRegisterDelta>
      <timerKeepAliveExpires>120</timerKeepAliveExpires>
      <timerSubscribeExpires>120</timerSubscribeExpires>
      <timerSubscribeDelta>5</timerSubscribeDelta>
      <timerT1>500</timerT1>
      <timerT2>4000</timerT2>
      <maxRedirects>70</maxRedirects>
      <remotePartyID>false</remotePartyID>
      <userInfo>None</userInfo>
   </sipStack>
   <autoAnswerTimer>1</autoAnswerTimer>
   <autoAnswerAltBehavior>false</autoAnswerAltBehavior>
   <autoAnswerOverride>true</autoAnswerOverride>
   <transferOnhookEnabled>false</transferOnhookEnabled>
   <enableVad>false</enableVad>
   <dtmfAvtPayload>101</dtmfAvtPayload>
   <dtmfDbLevel>3</dtmfDbLevel>
   <dtmfOutofBand>avt</dtmfOutofBand>
   <alwaysUsePrimeLine>false</alwaysUsePrimeLine>
   <alwaysUsePrimeLineVoiceMail>false</alwaysUsePrimeLineVoiceMail>
   <kpml>3</kpml>
   <phoneLabel>Company</phoneLabel>
   <stutterMsgWaiting>1</stutterMsgWaiting>
   <callStats>false</callStats>
   <silentPeriodBetweenCallWaitingBursts>10</silentPeriodBetweenCallWaitingBursts>
   <disableLocalSpeedDialConfig>false</disableLocalSpeedDialConfig>
   <sipLines>
      <line button="1">
         <featureID>9</featureID>
         <featureLabel>Company</featureLabel>
         <proxy>192.168.1.3</proxy>
       <ProxyPort>5060</ProxyPort>
         <sipPort>5060</sipPort>
         <name>201</name>
         <displayName>Company</displayName>
         <autoAnswer>
         <autoAnswerEnabled>2</autoAnswerEnabled>
         </autoAnswer>
         <callWaiting>3</callWaiting>
         <authName>201</authName>
         <authPassword>password</authPassword>
         <sharedLine>false</sharedLine>
         <messageWaitingLampPolicy>1</messageWaitingLampPolicy>
         <messagesNumber>*97</messagesNumber>
         <ringSettingIdle>4</ringSettingIdle>
         <ringSettingActive>5</ringSettingActive>
         <contact>201</contact>
         <forwardCallInfoDisplay>
            <callerName>true</callerName>
            <callerNumber>false</callerNumber>
            <redirectedNumber>false</redirectedNumber>
            <dialedNumber>true</dialedNumber>
         </forwardCallInfoDisplay>
      </line>
      <line button="3">
         <featureID>9</featureID>
         <featureLabel>Company</featureLabel>
         <proxy>192.168.1.3</proxy>
         <sipPort>5060</sipPort>
       <ProxyPort>5060</ProxyPort>
         <name>201</name>
         <displayName>Company</displayName>
         <autoAnswer>
            <autoAnswerEnabled>2</autoAnswerEnabled>
         </autoAnswer>
         <callWaiting>3</callWaiting>
         <authName>201</authName>
         <authPassword>password</authPassword>
         <sharedLine>false</sharedLine>
         <messageWaitingLampPolicy>1</messageWaitingLampPolicy>
         <messagesNumber>*99</messagesNumber>
         <ringSettingIdle>4</ringSettingIdle>
         <ringSettingActive>5</ringSettingActive>
         <contact>201</contact>
         <forwardCallInfoDisplay>
            <callerName>true</callerName>
            <callerNumber>false</callerNumber>
            <redirectedNumber>false</redirectedNumber>
            <dialedNumber>true</dialedNumber>
         </forwardCallInfoDisplay>
      </line>
      <line button="5">
         <featureID>9</featureID>
         <featureLabel>Company</featureLabel>
         <proxy>192.168.1.3</proxy>
         <sipPort>5060</sipPort>
       <ProxyPort>5060</ProxyPort>
         <name>201</name>
         <displayName>Company</displayName>
         <autoAnswer>
            <autoAnswerEnabled>2</autoAnswerEnabled>
         </autoAnswer>
         <callWaiting>3</callWaiting>
         <authName>201</authName>
         <authPassword>password</authPassword>
         <sharedLine>false</sharedLine>
         <messageWaitingLampPolicy>1</messageWaitingLampPolicy>
         <messagesNumber>*99</messagesNumber>
         <ringSettingIdle>4</ringSettingIdle>
         <ringSettingActive>5</ringSettingActive>
         <contact>201</contact>
         <forwardCallInfoDisplay>
            <callerName>true</callerName>
            <callerNumber>false</callerNumber>
            <redirectedNumber>false</redirectedNumber>
            <dialedNumber>true</dialedNumber>
         </forwardCallInfoDisplay>
      </line>
      <line button="7">
         <featureID>9</featureID>
         <featureLabel>Company</featureLabel>
         <proxy>192.168.1.3</proxy>
         <sipPort>5060</sipPort>
       <ProxyPort>5060</ProxyPort>
         <name>201</name>
         <displayName>Company</displayName>
         <autoAnswer>
            <autoAnswerEnabled>2</autoAnswerEnabled>
         </autoAnswer>
         <callWaiting>3</callWaiting>
         <authName>201</authName>
         <authPassword>password</authPassword>
         <sharedLine>false</sharedLine>
         <messageWaitingLampPolicy>1</messageWaitingLampPolicy>
         <messagesNumber>*99</messagesNumber>
         <ringSettingIdle>4</ringSettingIdle>
         <ringSettingActive>5</ringSettingActive>
         <contact>201</contact>
         <forwardCallInfoDisplay>
            <callerName>true</callerName>
            <callerNumber>false</callerNumber>
            <redirectedNumber>false</redirectedNumber>
            <dialedNumber>true</dialedNumber>
         </forwardCallInfoDisplay>
      </line>
   </sipLines>
   <voipControlPort>5060</voipControlPort>
   <startMediaPort>10000</startMediaPort>
   <stopMediaPort>20000</stopMediaPort>
   <dscpForAudio>184</dscpForAudio>
   <ringSettingBusyStationPolicy>0</ringSettingBusyStationPolicy>
   <dialTemplate>dialplan.xml</dialTemplate>
   <softKeyFile></softKeyFile>
</sipProfile>
<commonProfile>
   <phonePassword></phonePassword>
   <backgroundImageAccess>true</backgroundImageAccess>
   <callLogBlfEnabled>2</callLogBlfEnabled>
</commonProfile>
<loadInformation>SIP45.8-4-2S</loadInformation>
<vendorConfig>
   <disableSpeaker>false</disableSpeaker>
   <disableSpeakerAndHeadset>false</disableSpeakerAndHeadset>
   <pcPort>0</pcPort>
   <settingsAccess>1</settingsAccess>
   <garp>0</garp>
   <voiceVlanAccess>0</voiceVlanAccess>
   <videoCapability>0</videoCapability>
   <autoSelectLineEnable>0</autoSelectLineEnable>
   <webAccess>0</webAccess>
   <daysDisplayNotActive>1,2,3,4,5,6,7</daysDisplayNotActive>
   <displayOnTime>00:00</displayOnTime>
   <displayOnDuration>00:00</displayOnDuration>
   <displayIdleTimeout>00:00</displayIdleTimeout>
   <spanToPCPort>1</spanToPCPort>
   <loggingDisplay>1</loggingDisplay>
   <loadServer></loadServer>
</vendorConfig>
<userLocale>
   <name></name>
   <uid></uid>
   <langCode>en_UK</langCode>
   <version>1.0.0.0-1</version>
   <winCharSet>iso-8859-1</winCharSet>
</userLocale>
<networkLocale></networkLocale>
<networkLocaleInfo>
   <name></name>
   <uid></uid>
   <version>1.0.0.0-1</version>
</networkLocaleInfo>   
<deviceSecurityMode>1</deviceSecurityMode>
<idleURL></idleURL>
<informationURL></informationURL>
<messagesURL></messagesURL>
<proxyServerURL></proxyServerURL>
<dscpForSCCPPhoneConfig>96</dscpForSCCPPhoneConfig>
<dscpForSCCPPhoneServices>0</dscpForSCCPPhoneServices>
<dscpForCm2Dvce>96</dscpForCm2Dvce>
<transportLayerProtocol>4</transportLayerProtocol>
<capfAuthMode>0</capfAuthMode>
<capfList>
   <capf>
      <phonePort>3804</phonePort>
   </capf>
</capfList>
<certHash></certHash>
<encrConfig>false</encrConfig>
</device>
joekane
Newsterisk
 
Posts: 6
Joined: Wed Nov 22, 2006 2:12 pm

Re: Cisco IP Communicator 8.6.1 with Asterisk

Postby bira_more » Thu Mar 29, 2012 8:09 am

Did you do necessary things in sip.conf, or in your sip_friends table?
You should have in your sip.conf something like (for first line):

[Company]
type=friend
username=201
host=dynamic
secret=password
dtmfmode=rfc2833
insecure=invite,port
canreinvite=no
nat=yes
qualify=yes

Please specify - you cant make calls, or you cant get calls?
You can check in Asterisk console
sip show peers
This way you will see registered peers.
bira_more
Astmaster
 
Posts: 465
Joined: Thu Dec 21, 2006 10:56 pm

Re: Cisco IP Communicator 8.6.1 with Asterisk

Postby joekane » Thu Mar 29, 2012 9:19 am

Here is the sip.conf extension

[201]
deny=0.0.0.0/0.0.0.0
type=friend
secret=password
qualify=yes
port=5060
pickupgroup=
permit=0.0.0.0/0.0.0.0
nat=yes
mailbox=201@device
host=dynamic
dtmfmode=rfc2833
dial=SIP/201
context=from-internal
canreinvite=no
callgroup=
callerid=device <201>
accountcode=
call-limit=50
insecure=invite,port

The phone wont register - so I cant make calls in or out

Show sip peers is

Name/username Host Dyn Nat ACL Port Status
201 (Unspecified) D N A 0 UNKNOWN
joekane
Newsterisk
 
Posts: 6
Joined: Wed Nov 22, 2006 2:12 pm

Re: Cisco IP Communicator 8.6.1 with Asterisk

Postby bira_more » Thu Mar 29, 2012 9:41 am

Put
username=201

and remove deny and permit.
Both declarations should do nothing - first you deny all addresses, second - allow all.
Of course then you should type in console
sip reload
bira_more
Astmaster
 
Posts: 465
Joined: Thu Dec 21, 2006 10:56 pm

Re: Cisco IP Communicator 8.6.1 with Asterisk

Postby joekane » Thu Mar 29, 2012 10:16 am

Here is the setup now

[201]
username=201
type=friend
secret=password
qualify=yes
port=5060
pickupgroup=
nat=no
mailbox=201@device
host=dynamic
dtmfmode=rfc2833
dial=SIP/201
context=from-internal
canreinvite=no
callgroup=
callerid=device <201>
accountcode=
call-limit=50
insecure=invite,port

-----------------------

Same result - stuck on Registering?
Is the xml config ok?
joekane
Newsterisk
 
Posts: 6
Joined: Wed Nov 22, 2006 2:12 pm

Re: Cisco IP Communicator 8.6.1 with Asterisk

Postby bira_more » Fri Mar 30, 2012 7:05 am

I cant say nothing about xml - I have no experience there.
But you can do one more thing:
1. Turnoff / disconnect all devices from Asterisk (if there are more)
2. In Asterisk console type:
sip set debug on
3. Turn on device
Command above will generate bunch of messages. You can try to limit unwanted messages setting debug by IP (of device)
In that messages you must look at:
1. If device makes any attempts to connect.
2. If device makes attempts - you can see why Asterisk refuses connection.
bira_more
Astmaster
 
Posts: 465
Joined: Thu Dec 21, 2006 10:56 pm


Return to Asterisk Support

Who is online

Users browsing this forum: No registered users and 22 guests