GUI does not have necessary privileges

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Support, Moderator

GUI does not have necessary privileges

Postby vitali » Wed Aug 20, 2008 10:14 am

Hello.

I just installed Asterisk, and i'm trying to access configuration panel.

I'm trying to get here:
http://localhost:8088/asterisk/static/c ... basic.html

but it redirects me here:
http://localhost:8088/asterisk/static/config/index.html


So I tried loging in using user and password specified in manager.conf, but it gives the following error:

The GUI does not have necessary privileges.
Please check the manager permissions for the user !


Here is my manager.conf:

Code: Select all
;
; AMI - The Asterisk Manager Interface
;
; Third party application call management support and PBX event supervision
;
; This configuration file is read every time someone logs in
;
; Use the "manager list commands" at the CLI to list available manager commands
; and their authorization levels.
;
; "manager show command <command>" will show a help text.
;
; ---------------------------- SECURITY NOTE -------------------------------
; Note that you should not enable the AMI on a public IP address. If needed,
; block this TCP port with iptables (or another FW software) and reach it
; with IPsec, SSH, or SSL vpn tunnel.  You can also make the manager
; interface available over http if Asterisk's http server is enabled in
; http.conf and if both "enabled" and "webenabled" are set to yes in
; this file.  Both default to no.  httptimeout provides the maximum
; timeout in seconds before a web based session is discarded.  The
; default is 60 seconds.
;
[general]
displaysystemname = yes
enabled = yes
webenabled = yes
port = 5038

;httptimeout = 60
; a) httptimeout sets the Max-Age of the http cookie
; b) httptimeout is the amount of time the webserver waits
;    on a action=waitevent request (actually its httptimeout-10)
; c) httptimeout is also the amount of time the webserver keeps
;    a http session alive after completing a successful action

bindaddr = 0.0.0.0
;displayconnects = yes
;
; Add a Unix epoch timestamp to events (not action responses)
;
;timestampevents = yes

[mark]
secret = mysecret
;deny=0.0.0.0/0.0.0.0
;permit=209.16.236.73/255.255.255.0
permit=127.0.0.1/255.255.255.0
;
; If the device connected via this user accepts input slowly,
; the timeout for writes to it can be increased to keep it
; from being disconnected (value is in milliseconds)
;
writetimeout = 100
;
; Authorization for various classes
;read = system,call,log,verbose,command,agent,user,config
;write = system,call,log,verbose,command,agent,user,config
read = all
write = all



and here is my http.conf:
Code: Select all
;
; Asterisk Builtin mini-HTTP server
;
;
[general]
;
; Whether HTTP interface is enabled or not.  Default is no.
;
enabled=yes
;
; Whether Asterisk should serve static content from http-static
; Default is no.
;
enablestatic=yes
;
; Address to bind to.  Default is 0.0.0.0
;
bindaddr=127.0.0.1
;
; Port to bind to (default is 8088)
;
bindport=8088
;
; Prefix allows you to specify a prefix for all requests
; to the server.  The default is "asterisk" so that all
; requests must begin with /asterisk
;
prefix=asterisk

; The post_mappings section maps URLs to real paths on the filesystem.  If a
; POST is done from within an authenticated manager session to one of the
; configured POST mappings, then any files in the POST will be placed in the
; configured directory.
;
;[post_mappings]
;
; In this example, if the prefix option is set to "asterisk", then using the
; POST URL: /asterisk/uploads will put files in /var/lib/asterisk/uploads/.
;uploads = /var/lib/asterisk/uploads/
;


Any one got any clues?
vitali
Newsterisk
 
Posts: 2
Joined: Wed Aug 20, 2008 10:01 am

Postby alexkink » Wed Aug 20, 2008 3:57 pm

This is caused by the fact that the GUI application (running on the Asterisk HTTP server) doesn't have enough permissions to write to the files in /etc/asterisk/
alexkink
Newsterisk
 
Posts: 6
Joined: Wed Aug 20, 2008 10:21 am

Postby sgtjake » Sat Aug 30, 2008 12:07 am

i'm having the same problem. What is the fix?
sgtjake
Newsterisk
 
Posts: 1
Joined: Sat Aug 30, 2008 12:02 am

Postby alexkink » Sat Aug 30, 2008 6:44 am

sgtjake wrote:i'm having the same problem. What is the fix?
I'm not exactly sure which user is running the Asterisk HTTP service, but you have to give that user full permissions to modify the files in /etc/asterisk
Use chmod to give permissions: http://en.wikipedia.org/wiki/Chmod
alexkink
Newsterisk
 
Posts: 6
Joined: Wed Aug 20, 2008 10:21 am

Postby rconnect » Sat Sep 06, 2008 4:22 pm

I am getting the same message, after compiling Asterik-Gui

The GUI does not have necessary privileges.
Please check the manager permissions for the user !
rconnect
Newsterisk
 
Posts: 1
Joined: Sat Sep 06, 2008 1:19 pm

Postby KoenraadL » Wed Sep 10, 2008 12:53 am

I'm having the same problem, after updating yesterday. Before I had the original *Now from CD.
I modifying the owner of all files in /etc/asterisk to raa-web:raa-web (user running ligHHTPd) and the directory-ownership of /etc/asterisk itself. This didn't help.

So I'm stuck also if nobody has a solution.

Regards,
Koenraad Lelong.
KoenraadL
Newsterisk
 
Posts: 3
Joined: Mon Sep 08, 2008 5:11 am

Postby kanour » Thu Sep 11, 2008 12:04 am

I am having same issues.

At least whoever wrote the update notes at http://asterisknow.org/install-related could tell us what to backup to revers to the old GUI in case of something does not work.
kanour
Newsterisk
 
Posts: 24
Joined: Mon Sep 08, 2008 5:12 am

Postby KoenraadL » Thu Sep 11, 2008 1:18 am

Hi,
Yesterday evening I tried to chmod 777 everything in /etc/asterisk and /etc/asterisk-gui, but it didn't help.
Reading the link provided, I'm going to check my http.conf and manager.conf.
If this is unsuccessfull, I'm going to re-install. Unfortunately I didn't take a snapshot of my virtual machine. Next time I'll be smarter and I'm going to disable the automatic updates !
KoenraadL
Newsterisk
 
Posts: 3
Joined: Mon Sep 08, 2008 5:11 am

Postby kanour » Thu Sep 11, 2008 2:00 am

kanour
Newsterisk
 
Posts: 24
Joined: Mon Sep 08, 2008 5:12 am

Postby KoenraadL » Thu Sep 11, 2008 1:21 pm

I got it working again.
In manager.conf I modified the admin's read/write lines to include "originate,read,write"
Another thing I encountered is that I had to use a FQDN to enter the gui.
KoenraadL
Newsterisk
 
Posts: 3
Joined: Mon Sep 08, 2008 5:11 am


Return to Asterisk Support

Who is online

Users browsing this forum: Google [Bot] and 20 guests